2108 Forum

22/11/18  The forum is causing problems. I’ve replied to several posts but not all are appearing even though they show that I was the last to post a reply. Until this is fixed, I will post answers above the forum topics.

04/12/2018

Seth forum has moved to GitHub Issues
https://github.com/AndyPiddock/Seth/issues/

TinyIDE forum has moved to GitHub Issues
http://https//github.com/AndyPiddock/TinyIDE/issues

To be able to post or comment on issues you will need a free GitHub account.

I’ve left the old forums below for reference only, please use the GitHub Issues from now on, thank you.


 

 

You need to log in to create posts and topics.

LC 8.1.3 / LC 9 dp6 issue

Edit mode seems to be impacted on all systems that I use (Win 10/Mac OS).  I have an Indy license and have tried with LC 8.0.1, 8.0.2, 8.1.3, and 9 dp6.  What happens is that when in edit mode, the mouse click is still sent to buttons (so they execute the script).  Right-click will not bring up a contextual menu.  The buttons still end up selected.  Changing between edit and run works fine.  If I pull the tidyide stack out of the plugins folder/directory then behavior goes back to normal.  It doesn't matter how I switch modes (using the tinyide button, 4W devo, tools stack).  I tried with only the plugins that come with an installation and had the same behavior.

Thanks for the report.

Confirmed bug affecting all platforms. I will post here when a fix update is available.

 

I've been playing around with this a little trying to see what I can find a work around.  I was able to avoid the issue by not having the plugin load at launch.  If I manually launch it, then it appears to work correctly.

Thanks bwmilby,

Yes the issue only happens when TinyIDE is auto launched via the Plugin settings in LC.

Is this a LC bug or is this designed?

I tested a few other plugins and some also exhibit problems with the context menus (but not all).

It looks like auto launched plugins are placed higher in the message hierarchy than when manually launched.

I have workaround for this which should be out later this week.